Inventory returns 0 Units for SKU

FBA Inventory returns 0 Units for SKU

When testing your inventory you may receive a message that reads:

"Inventory Test Success! There are 0 units of XXXXXX in FBA stock."

This may be a little confusing as the inventory connection test was a success, however the test reported 0 units for a particular SKU and you KNOW that you have units available in your FBA inventory for that SKU.

It’s possible that you need to double-check your setting for Marketplace ID and make sure that if you have multiple Marketplace IDs on your Amazon Seller Central account that you are using the correct one in your WooCommerce Amazon Fulfillment settings.

To quickly see what Marketplace ID’s you have available on your account, you can re-step through the MWS Registration process that you did when you first set everything up. The IDs will be the same as the ones it gave you before, but it will show you all your Marketplace ID’s associated with your Amazon Seller Central login.

Check what Marketplace ID’s you have available on your account:

  1. Start here: https://sellercentral.amazon.com/gp/mws/registration/register.html
  2. Select the top option in the first step (“I want to connect to my own data”)
  3. Click through and on the confirmation screen you’ll see something like the attached.

Take note of both (or all) Marketplace IDs. Try replacing the one you have in your settings with the other one and re-run the full inventory sync and check the log then.

Feedback and Knowledge Base